summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-06-04 01:31:03 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-06-04 01:31:03 +0000
commit43b4ae2de0778f3c579fcb3f694890dd4a3981a4 (patch)
treeb2faebbb7c9deaf1ee3005e28fab0a53b5c477f3 /openwrt
parent30023faa50b5c5aaaff9ae8f105c6f27c02a7b77 (diff)
don't compile libipkg in busybox if ipkg is disabled
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3901 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/busybox/patches/911-ipkg.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/openwrt/package/busybox/patches/911-ipkg.patch b/openwrt/package/busybox/patches/911-ipkg.patch
index 7b6437c98..1d7a4e357 100644
--- a/openwrt/package/busybox/patches/911-ipkg.patch
+++ b/openwrt/package/busybox/patches/911-ipkg.patch
@@ -203,16 +203,16 @@ diff -ruN busybox-1.1.2-orig/archival/libipkg/Makefile.in busybox-1.1.2+ipkg-0.9
+ str_util.c \
+ xsystem.c \
+
-+LIBIPKG-y += $(LIBIPKG_CORE_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_CMD_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_DB_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_LIST_SOURCES)
-+LIBIPKG-y += $(LIBIPKG_UTIL_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_CORE_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_CMD_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_DB_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_LIST_SOURCES)
++LIBIPKG-$(CONFIG_IPKG) += $(LIBIPKG_UTIL_SOURCES)
+LIBIPKG_OBJS=$(patsubst %.c,$(LIBIPKG_DIR)%.o, $(LIBIPKG-y))
+
+CFLAGS += -DIPKG_LIB -DIPKGLIBDIR="\"/usr/lib\"" -DHOST_CPU_STR="\"$(TARGET_ARCH)\""
+
-+libraries-y += $(LIBIPKG_DIR)$(LIBIPKG_AR)
++libraries-$(CONFIG_IPKG) += $(LIBIPKG_DIR)$(LIBIPKG_AR)
+
+$(LIBIPKG_DIR)$(LIBIPKG_AR): $(LIBIPKG_OBJS)
+ $(do_ar)