summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-17 01:07:20 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-17 01:07:20 +0000
commit33ac34cace5948dc553ee9a231216d0bc962e3f1 (patch)
treec0f8183072766801c0bc7fa9d1952750a715ccb5 /openwrt
parentf3dac60bcef93ecb237731a0318847959b9c0126 (diff)
fix rebuild of pwlib and openh323 after root_clean.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3791 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/openh323/Makefile8
-rw-r--r--openwrt/package/pwlib/Makefile8
2 files changed, 6 insertions, 10 deletions
diff --git a/openwrt/package/openh323/Makefile b/openwrt/package/openh323/Makefile
index a17ac0099..f85e623b6 100644
--- a/openwrt/package/openh323/Makefile
+++ b/openwrt/package/openh323/Makefile
@@ -49,6 +49,7 @@ $(PKG_BUILD_DIR)/.configured:
--enable-audio \
--disable-video \
);
+ ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
touch $@
@@ -58,11 +59,8 @@ $(PKG_BUILD_DIR)/.built:
optnoshared
touch $@
-install-link:
- ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-
uninstall-link:
- rm -rf $(BUILD_DIR)/$(PKG_NAME)
+ rm -f $(BUILD_DIR)/$(PKG_NAME)
-compile-targets: $(PKG_BUILD_DIR)/.built install-link
+compile-targets: $(PKG_BUILD_DIR)/.built
clean-targets: uninstall-link
diff --git a/openwrt/package/pwlib/Makefile b/openwrt/package/pwlib/Makefile
index 66e806dc1..68857ff27 100644
--- a/openwrt/package/pwlib/Makefile
+++ b/openwrt/package/pwlib/Makefile
@@ -88,6 +88,7 @@ $(PKG_BUILD_DIR)/.configured:
--disable-wavfile \
--disable-xmlrpc \
);
+ ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
touch $@
$(PKG_BUILD_DIR)/.built:
@@ -96,11 +97,8 @@ $(PKG_BUILD_DIR)/.built:
optnoshared
touch $@
-install-link:
- ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-
uninstall-link:
- rm -rf $(BUILD_DIR)/$(PKG_NAME)
+ rm -f $(BUILD_DIR)/$(PKG_NAME)
-compile-targets: $(PKG_BUILD_DIR)/.built install-link
+compile-targets: $(PKG_BUILD_DIR)/.built
clean-targets: uninstall-link