summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-01 20:30:35 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-01 20:30:35 +0000
commit1a834a8ba7498d428233f80653de302e1d961196 (patch)
tree8416250f4341e1cd1d4bdc3a2e10c8fdd8eb07ce /openwrt
parent263e63a5f9994078dbc09914568f551ff6e50743 (diff)
fix hostapd (add missed changes from [3564])
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3575 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/Makefile2
-rw-r--r--openwrt/package/depend.mk6
2 files changed, 6 insertions, 2 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 09df4fe2b..cae460933 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -69,7 +69,7 @@ package-$(BR2_COMPILE_GSM) += gsm
package-$(BR2_PACKAGE_HASERL) += haserl
package-$(BR2_PACKAGE_HEYU) += heyu
package-$(BR2_PACKAGE_HOSTAP_UTILS) += hostap-utils
-package-$(BR2_PACKAGE_HOSTAPD) += hostapd
+package-$(BR2_COMPILE_HOSTAPD) += hostapd
package-$(BR2_COMPILE_HOWL) += howl
package-$(BR2_PACKAGE_HTPDATE) += htpdate
package-$(BR2_PACKAGE_HTTPING) += httping
diff --git a/openwrt/package/depend.mk b/openwrt/package/depend.mk
index f973391c8..6ed55179b 100644
--- a/openwrt/package/depend.mk
+++ b/openwrt/package/depend.mk
@@ -29,7 +29,6 @@ iptables-snmp-compile: net-snmp-compile
iptraf-compile: ncurses-compile
ipsec-tools-compile: openssl-compile
jamvm-compile: libffi-sable-compile zlib-compile sablevm-classpath-compile
-hostapd-compile: openssl-compile wireless-tools-compile
httping-compile: openssl-compile
kismet-compile: uclibc++-compile libpcap-compile ncurses-compile
l2tpns-compile: libcli-compile
@@ -138,6 +137,11 @@ ifneq ($(BR2_PACKAGE_FREERADIUS_MOD_SQL_PGSQL),)
freeradius-compile: postgresql-compile
endif
+hostapd-compile: wireless-tools-compile
+ifneq ($(BR2_PACKAGE_HOSTAPD),)
+hostapd-compile: openssl-compile
+endif
+
ifneq ($(BR2_PACKAGE_MINI_HTTPD_MATRIXSSL),)
mini_httpd-compile: matrixssl-compile
endif