summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-01 14:51:48 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-01 14:51:48 +0000
commit185ad006574292205c559c530cebe27fb52edc8e (patch)
treea8b802d2c983f234091f99f4acf68872fa394d8e /openwrt
parent20f6233941a0393bca7f4ab69b93b1ff61bac4a6 (diff)
load of ide modules at boot (closes: #439)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3565 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/Config.in6
-rw-r--r--openwrt/target/linux/generic-2.4/modules.mk2
2 files changed, 7 insertions, 1 deletions
diff --git a/openwrt/target/linux/Config.in b/openwrt/target/linux/Config.in
index e81b099be..7a416753a 100644
--- a/openwrt/target/linux/Config.in
+++ b/openwrt/target/linux/Config.in
@@ -287,6 +287,12 @@ config BR2_PACKAGE_KMOD_IDE
help
Kernel modules for IDE support
useful for usb mass storage devices (e.g. on WL-HDD)
+
+ Includes:
+ - ide-core
+ - ide-detect
+ - ide-disk
+ - pdc202xx_old
config BR2_PACKAGE_KMOD_LOOP
prompt "kmod-loop......................... Loop mount support"
diff --git a/openwrt/target/linux/generic-2.4/modules.mk b/openwrt/target/linux/generic-2.4/modules.mk
index 705b702e8..f35e9ba56 100644
--- a/openwrt/target/linux/generic-2.4/modules.mk
+++ b/openwrt/target/linux/generic-2.4/modules.mk
@@ -110,7 +110,7 @@ $(eval $(call KMOD_template,IP6TABLES,ip6tables,\
$(eval $(call KMOD_template,IDE,ide,\
$(MODULES_DIR)/kernel/drivers/ide/*.o \
$(MODULES_DIR)/kernel/drivers/ide/*/*.o \
-,CONFIG_IDE))
+,CONFIG_IDE,,20,pdc202xx_old ide-core ide-detect ide-disk))
$(eval $(call KMOD_template,LOOP,loop,\
$(MODULES_DIR)/kernel/drivers/block/loop.o \