summaryrefslogtreecommitdiffstats
path: root/openwrt/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-03-03 06:25:04 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-03-03 06:25:04 +0000
commit292f4602665c295f41287453ed883a47e8eec406 (patch)
treee1d08f05c28225b26e90b1a5f3889d752e9d22e8 /openwrt/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch
parent87d22831816ee2bf6c7823117eb132a8b502bc56 (diff)
add gcc 4.1.0
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3302 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch')
-rw-r--r--openwrt/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/openwrt/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch b/openwrt/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch
new file mode 100644
index 000000000..23fce7544
--- /dev/null
+++ b/openwrt/toolchain/gcc/4.1.0/602-sdk-libstdc++-includes.patch
@@ -0,0 +1,20 @@
+--- gcc-4.1.0/libstdc++-v3/fragment.am 2005-03-21 11:40:14.000000000 -0600
++++ gcc-4.1.0-patched/libstdc++-v3/fragment.am 2005-04-25 20:14:39.856251785 -0500
+@@ -21,5 +21,5 @@
+ $(WARN_FLAGS) $(WERROR) -fdiagnostics-show-location=once
+
+ # -I/-D flags to pass when compiling.
+-AM_CPPFLAGS = $(GLIBCXX_INCLUDES)
++AM_CPPFLAGS = $(GLIBCXX_INCLUDES) -I$(toplevel_srcdir)/include
+
+--- gcc-4.1.0/libstdc++-v3/libmath/Makefile.am 2005-03-21 11:40:18.000000000 -0600
++++ gcc-4.1.0-patched/libstdc++-v3/libmath/Makefile.am 2005-04-25 20:14:39.682280735 -0500
+@@ -35,7 +35,7 @@
+
+ libmath_la_SOURCES = stubs.c
+
+-AM_CPPFLAGS = $(CANADIAN_INCLUDES)
++AM_CPPFLAGS = $(CANADIAN_INCLUDES) -I$(toplevel_srcdir)/include
+
+ # Only compiling "C" sources in this directory.
+ LIBTOOL = @LIBTOOL@ --tag CC