summaryrefslogtreecommitdiffstats
path: root/openwrt/target
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 14:37:56 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 14:37:56 +0000
commit318467b6beee0cac332f093871aaa6bb02911a0f (patch)
tree22459ee2ad5f10f269b2abaa783a9981e4ccb62d /openwrt/target
parentd88af1c653ecd81280bac2fcce0a28dcae5ddf95 (diff)
fix unnecessary recompiling of packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2239 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile10
-rw-r--r--openwrt/target/linux/linux-2.6/Makefile10
2 files changed, 10 insertions, 10 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index f455c92bd..4fd8e2104 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -251,6 +251,11 @@ $(STAGING_DIR)/include/linux/version.h: $(LINUX_DIR)/.configured
$(STAMP_DIR)/.linux-compile: $(LINUX_DIR)/.modules_done
@mkdir -p $(STAMP_DIR)
@$(MAKE) $(TARGETS)
+ ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
+ @$(TRACE) target/linux/package
+ $(MAKE) -C $(TOPDIR)/target/linux/package \
+ $(KPKG_MAKEOPTS) \
+ compile
touch $@
$(TARGET_MODULES_DIR):
@@ -271,11 +276,6 @@ prepare: $(LINUX_DIR)/.configured
compile:
@$(PKG_TRACE) Compiling...
$(MAKE) $(STAMP_DIR)/.linux-compile $(MAKE_TRACE)
- ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
- @$(TRACE) target/linux/package
- $(MAKE) -C $(TOPDIR)/target/linux/package \
- $(KPKG_MAKEOPTS) \
- compile
install: compile $(TARGET_MODULES_DIR) $(KERNEL_IPKG)
rm -rf $(LINUX_BUILD_DIR)/root*
diff --git a/openwrt/target/linux/linux-2.6/Makefile b/openwrt/target/linux/linux-2.6/Makefile
index 7c254755d..9ff3ed769 100644
--- a/openwrt/target/linux/linux-2.6/Makefile
+++ b/openwrt/target/linux/linux-2.6/Makefile
@@ -235,6 +235,11 @@ $(KERNEL_IPKG):
$(STAMP_DIR)/.linux-compile: $(LINUX_DIR)/.modules_done
@mkdir -p $(STAMP_DIR)
@$(MAKE) $(TARGETS)
+ ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
+ @$(TRACE) target/linux/package
+ $(MAKE) -C $(TOPDIR)/target/linux/package \
+ $(KPKG_MAKEOPTS) \
+ compile
touch $@
source: $(DL_DIR)/$(LINUX_SOURCE)
@@ -242,11 +247,6 @@ prepare: $(LINUX_DIR)/.configured
compile:
@$(PKG_TRACE) Compiling...
$(MAKE) $(STAMP_DIR)/.linux-compile $(MAKE_TRACE)
- ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
- @$(TRACE) target/linux/package
- $(MAKE) -C $(TOPDIR)/target/linux/package \
- $(KPKG_MAKEOPTS) \
- compile
install: compile $(TARGET_MODULES_DIR) $(KERNEL_IPKG)
rm -rf $(LINUX_BUILD_DIR)/root*