summaryrefslogtreecommitdiffstats
path: root/openwrt/target
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-12 17:51:31 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-12 17:51:31 +0000
commit04ea7cf312317db9bacf2cc7f0f15790e812636e (patch)
tree1f1861f78030134442118bceba1f9f1579cdd85c /openwrt/target
parentdc97347cdf6a1987c40d6285e5b1674dddb9e252 (diff)
fix squashfs build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1219 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/linux/image/squashfs.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
index e9a95de56..917a69ab8 100644
--- a/openwrt/target/linux/image/squashfs.mk
+++ b/openwrt/target/linux/image/squashfs.mk
@@ -12,8 +12,9 @@ $(KDIR)/root.squashfs:
@mkdir -p $(KDIR)/root/jffs
$(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -noappend -root-owned -le
+squashfs-install: $(KDIR)/root.squashfs
+ $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
+
prepare: squashfs-prepare
compile: squashfs-compile
-install: $(KDIR)/root.squashfs
- $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
-
+install: squashfs-install