summaryrefslogtreecommitdiffstats
path: root/openwrt/target/squashfs-lzma/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-20 17:01:30 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-20 17:01:30 +0000
commitd4acdafcf724057bc9b718170c54b420f46c40b4 (patch)
treed54625559910142e0895d8a2318d003de21a286c /openwrt/target/squashfs-lzma/Makefile
parentb91216ac5fe33ba6166ab40915fdb8040f470b4e (diff)
add openwrt image builder to sdk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@688 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/squashfs-lzma/Makefile')
-rw-r--r--openwrt/target/squashfs-lzma/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/target/squashfs-lzma/Makefile b/openwrt/target/squashfs-lzma/Makefile
index 8da08b390..2664ed7e2 100644
--- a/openwrt/target/squashfs-lzma/Makefile
+++ b/openwrt/target/squashfs-lzma/Makefile
@@ -1,16 +1,16 @@
include $(TOPDIR)/rules.mk
include ./squashfslzmaroot.mk
-TARGETS:=$(BIN_DIR)/openwrt-generic-squashfs.trx
+SQUASHFS_TARGETS:=$(BIN_DIR)/openwrt-generic-squashfs.trx
prepare: $(SQUASHFSLZMA_DIR)/.unpacked
compile: squashfslzma
-install: $(TARGETS)
+install: $(SQUASHFS_TARGETS)
clean: squashfslzmaroot-dirclean
$(BIN_DIR)/openwrt-generic-squashfs.trx:
@mkdir -p $(TARGET_DIR)/jffs
- $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
+ PATH=$(TARGET_PATH) mksquashfs-lzma $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
PATH=$(TARGET_PATH) trx -o $@ $(BUILD_DIR)/loader.gz \
$(LINUX_IMAGE) $(IMAGE).squashfslzma