summaryrefslogtreecommitdiffstats
path: root/openwrt/target/lzma-loader/patches
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-02 19:06:50 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-02 19:06:50 +0000
commit0e222f60ff2b22a98094dedba70af5fe75e004c5 (patch)
tree486b047ba364c285eb3a1d526a1bc139b0eb3415 /openwrt/target/lzma-loader/patches
parenta36312d8f5fc9795bd1065ffb1801d04b50b2d1e (diff)
remove lzma loader config option (make it default) and move it from package/ to target/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@530 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/lzma-loader/patches')
-rw-r--r--openwrt/target/lzma-loader/patches/toolchain.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/openwrt/target/lzma-loader/patches/toolchain.patch b/openwrt/target/lzma-loader/patches/toolchain.patch
new file mode 100644
index 000000000..69617056b
--- /dev/null
+++ b/openwrt/target/lzma-loader/patches/toolchain.patch
@@ -0,0 +1,12 @@
+--- loader-0.03/Makefile 2005-03-28 22:15:24.569677129 +0400
++++ loader/Makefile 2005-03-28 22:16:42.339989214 +0400
+@@ -24,7 +24,8 @@
+
+ CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -O2 \
+ -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \
+- -ffunction-sections -pipe -mcpu=r4600 -mips2 -Wa,--trap -m4710a0kern
++ -ffunction-sections -pipe -mlong-calls -fno-common \
++ -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
+ CFLAGS += -DLOADADDR=$(TEXT_START) -D_LZMA_IN_CB
+
+ ASFLAGS = $(CFLAGS) -D__ASSEMBLY__ -DBZ_TEXT_START=$(BZ_TEXT_START)