summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 12:54:17 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 12:54:17 +0000
commitfe2a8d28d53a1f8b1ddd9af198f5b80a9a28b729 (patch)
treeab7d6697de4359c2dd3e72a533b34fe93b7723c2 /openwrt/target/linux
parent989a0208065f220c2a389fd4c7a23b92be720f97 (diff)
more V= fixes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2234 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux')
-rw-r--r--openwrt/target/linux/package/Makefile2
-rw-r--r--openwrt/target/linux/package/madwifi/Makefile4
-rw-r--r--openwrt/target/linux/package/openwrt/Makefile2
3 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index 6b7a85816..dc031fc47 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -39,7 +39,7 @@ MAKEOPTS:= BOARD="$(BOARD)" \
$(MAKEOPTS) \
prepare
-%-compile: %-prepare
+%-compile:
@$(TRACE) target/linux/package/$(patsubst %-compile,%,$@)-compile
$(MAKE) -C $(patsubst %-compile,%,$@) \
$(MAKEOPTS) \
diff --git a/openwrt/target/linux/package/madwifi/Makefile b/openwrt/target/linux/package/madwifi/Makefile
index 829eed8f4..2f06a2285 100644
--- a/openwrt/target/linux/package/madwifi/Makefile
+++ b/openwrt/target/linux/package/madwifi/Makefile
@@ -75,5 +75,5 @@ install-dev: $(STAGING_DIR)/usr/include/madwifi/net80211/ieee80211.h
uninstall-dev:
rm -rf $(STAGING_DIR)/usr/include/madwifi
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev
diff --git a/openwrt/target/linux/package/openwrt/Makefile b/openwrt/target/linux/package/openwrt/Makefile
index ef2c1cea0..f55b91d78 100644
--- a/openwrt/target/linux/package/openwrt/Makefile
+++ b/openwrt/target/linux/package/openwrt/Makefile
@@ -47,7 +47,7 @@ install: compile openwrt-install
openwrt-install:
$(IPKG) install $(IPKG_OPENWRT)
-compile: install-dev $(IPKG_OPENWRT)
+compile-targets: install-dev $(IPKG_OPENWRT)
install-dev:
mkdir -p $(STAGING_DIR)/usr/include
cp -fpR ./include/[a-z]* $(STAGING_DIR)/usr/include/