summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-31 21:55:38 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-31 21:55:38 +0000
commit8ddfbc1cca27d253ac40d9bd96549b8dd295dd2a (patch)
tree14f7893a727cac4a132e5d96f798aa20c1fde629 /openwrt/target/linux
parenta0d7aadf5ed57e4263b771ce001c5ffebabfac29 (diff)
fix "make target/linux/package/*-*" targets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3103 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux')
-rw-r--r--openwrt/target/linux/Makefile2
-rw-r--r--openwrt/target/linux/kernel.mk5
2 files changed, 7 insertions, 0 deletions
diff --git a/openwrt/target/linux/Makefile b/openwrt/target/linux/Makefile
index 2fff3b33a..626587b5b 100644
--- a/openwrt/target/linux/Makefile
+++ b/openwrt/target/linux/Makefile
@@ -45,6 +45,8 @@ compile: $(1)/$(2)-compile
rebuild: $(1)/$(2)-rebuild
$(BIN_DIR)/$(IB_NAME).tar.bz2 install: $(1)/$(2)-image
install-ib: $(1)/$(2)-install-ib
+package/%:
+ $(MAKE) -C $(2)-$(1) BOARD="$(2)" $$@
endif
.PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-rebuild $(1)/$(2)-install $(1)/$(2)-image $(1)/$(2)-install-ib
diff --git a/openwrt/target/linux/kernel.mk b/openwrt/target/linux/kernel.mk
index b1ac9473c..5406fae20 100644
--- a/openwrt/target/linux/kernel.mk
+++ b/openwrt/target/linux/kernel.mk
@@ -114,3 +114,8 @@ clean:
rm -f $(STAMP_DIR)/.linux-compile
rm -rf $(LINUX_BUILD_DIR)
rm -f $(TARGETS)
+
+package/%:
+ $(MAKE) -C $(TOPDIR)/target/linux/package \
+ $(KPKG_MAKEOPTS) \
+ $(patsubst package/%,%,$@)