summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-26 21:35:01 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-26 21:35:01 +0000
commit6df7acff9abc0043775f2683c877924bd15b857c (patch)
treead9240976968d2cc253913e8ce26dba6094c0e26 /openwrt/target/linux
parent83e7893f56b490836826ff1590af375b8bb7792d (diff)
bluetooth fixes from Tomas Vanek
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1571 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile1
-rw-r--r--openwrt/target/linux/linux-2.4/patches/brcm/005-bluetooth_sco_buffer_align.patch12
2 files changed, 13 insertions, 0 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 0e4658c2e..00d46933f 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -78,6 +78,7 @@ $(eval $(call KMOD_template,B44,b44,\
,CONFIG_B44))
$(eval $(call KMOD_template,BLUETOOTH,bluetooth,\
$(MODULES_DIR)/kernel/net/bluetooth/*.o \
+ $(MODULES_DIR)/kernel/net/bluetooth/rfcomm/*.o \
$(MODULES_DIR)/kernel/drivers/bluetooth/*.o \
,CONFIG_BLUEZ))
$(eval $(call KMOD_template,ARPT,arptables,\
diff --git a/openwrt/target/linux/linux-2.4/patches/brcm/005-bluetooth_sco_buffer_align.patch b/openwrt/target/linux/linux-2.4/patches/brcm/005-bluetooth_sco_buffer_align.patch
new file mode 100644
index 000000000..77ade1c8b
--- /dev/null
+++ b/openwrt/target/linux/linux-2.4/patches/brcm/005-bluetooth_sco_buffer_align.patch
@@ -0,0 +1,12 @@
+--- linux-2.4.30/drivers/bluetooth/hci_usb.c 2004-08-08 01:26:04.000000000 +0200
++++ linux-2.4.30/drivers/bluetooth/hci_usb.c 2005-07-25 20:12:11.000000000 +0200
+@@ -259,6 +259,9 @@
+ void *buf;
+
+ mtu = husb->isoc_in_ep->wMaxPacketSize;
++#ifdef CONFIG_BCM4710
++ mtu = (mtu + 1) & ~1; /* brcm: isoc buffers must be aligned on word boundary */
++#endif
+ size = mtu * HCI_MAX_ISOC_FRAMES;
+
+ buf = kmalloc(size, GFP_ATOMIC);