summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/x86-2.6/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-10 19:43:00 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-10 19:43:00 +0000
commit489f9455f265caba0edd3488fe9580e36418eb32 (patch)
tree227994a76fef5a3c7c651667756984dc69bddb2d /openwrt/target/linux/x86-2.6/Makefile
parent3224e1420fd9c58ce5bf3b67e871730be18f8fdd (diff)
large target/linux cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2877 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/x86-2.6/Makefile')
-rw-r--r--openwrt/target/linux/x86-2.6/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/openwrt/target/linux/x86-2.6/Makefile b/openwrt/target/linux/x86-2.6/Makefile
new file mode 100644
index 000000000..bfdc0757d
--- /dev/null
+++ b/openwrt/target/linux/x86-2.6/Makefile
@@ -0,0 +1,25 @@
+include $(TOPDIR)/rules.mk
+
+LINUX_VERSION:=2.6.15
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=cdf95e00f5111e31f78e1d97304d9522
+
+include ../rules.mk
+include ./config
+
+include ../generic-$(KERNEL)/modules.mk
+include ../kernel.mk
+
+
+$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
+ [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
+ [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
+ @cp config $(LINUX_DIR)/.config
+ touch $@
+
+$(LINUX_BUILD_DIR)/bzImage: $(LINUX_DIR)/vmlinux
+ $(MAKE) -C $(LINUX_DIR) V=1 CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) bzImage $(MAKE_TRACE)
+ cp -f $(LINUX_DIR)/arch/i386/boot/bzImage $@
+ touch $@
+
+compile: $(LINUX_BUILD_DIR)/bzImage