summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/rules.mk
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-15 08:23:42 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-15 08:23:42 +0000
commitfd5edd01ac012021d91dfaf2b10a48762cce90cd (patch)
tree31267aae1f006eba9c4b3c296da7215812490322 /openwrt/target/linux/rules.mk
parentcd0e91e2dbd785325a35d9dc2b9a5c3cd8c53b49 (diff)
fix kernel package and kernel modules dependency on it
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2492 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/rules.mk')
-rw-r--r--openwrt/target/linux/rules.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/openwrt/target/linux/rules.mk b/openwrt/target/linux/rules.mk
index be151ea10..8871fa442 100644
--- a/openwrt/target/linux/rules.mk
+++ b/openwrt/target/linux/rules.mk
@@ -17,11 +17,7 @@ else
KDEPEND_$(1):=$($(4))
endif
-ifeq ($$(strip $(5)),)
-IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE))
-else
-IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE)), $(5)
-endif
+IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)) $(foreach pkg,$(5),", $(pkg)")
PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk
I_$(1) := $(PKG_BUILD_DIR)/ipkg/$(2)