summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/rules.mk
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-16 09:49:24 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-16 09:49:24 +0000
commitf1ec3cf1276ff0bae1b58e6db55d48ade93c4a47 (patch)
tree96d25d6a70fd2bad1598acccc950281bfd405cd4 /openwrt/target/linux/rules.mk
parentea76c54e405c3d3bc52727d7909d827f68a9432b (diff)
add modules.d to kernel modules
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1454 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/rules.mk')
-rw-r--r--openwrt/target/linux/rules.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/openwrt/target/linux/rules.mk b/openwrt/target/linux/rules.mk
index 82ac46d58..39afadb34 100644
--- a/openwrt/target/linux/rules.mk
+++ b/openwrt/target/linux/rules.mk
@@ -29,7 +29,13 @@ $$(PKG_$(1)): $(LINUX_DIR)/.modules_done
$(SCRIPT_DIR)/make-ipkg-dir.sh $$(I_$(1)) ../control/kmod-$(2).control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
echo "Depends: $$(IDEPEND_$(1))" >> $$(I_$(1))/CONTROL/control
cp $(3) $$(I_$(1))/lib/modules/$(LINUX_VERSION)
- $(6)
+ifneq ($(6),)
+ mkdir -p $$(I_$(1))/etc/modules.d
+ for module in $(7); do \
+ echo $$$$module >> $$(I_$(1))/etc/modules.d/$(6)-$(2); \
+ done
+endif
+ $(8)
$(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR)
endef