summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package/shfs
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-01 17:30:26 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-01 17:30:26 +0000
commit24dc1f527d33afc44998f5b35a8de368c165f51d (patch)
treea24b15b28fc59486399663b610e84f85d0dd9739 /openwrt/target/linux/package/shfs
parent1c7ecc7b70a5848be016ea82df03a176b0a66636 (diff)
fix 2.6 modules pattern using a common LINUX_KMOD_SUFFIX variable,
fix alsa 2.6 build when arch != mipsel git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2311 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package/shfs')
-rw-r--r--openwrt/target/linux/package/shfs/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/target/linux/package/shfs/Makefile b/openwrt/target/linux/package/shfs/Makefile
index 3041826c0..ecb123872 100644
--- a/openwrt/target/linux/package/shfs/Makefile
+++ b/openwrt/target/linux/package/shfs/Makefile
@@ -43,7 +43,7 @@ $(PKG_BUILD_DIR)/.built:
$(IPKG_KMOD_SHFS):
install -m0755 -d $(IDIR_KMOD_SHFS)/lib/modules/$(LINUX_VERSION)
- cp -fpR $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.*o \
+ cp -fpR $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX) \
$(IDIR_KMOD_SHFS)/lib/modules/$(LINUX_VERSION)/
$(RSTRIP_KMOD) $(IDIR_KMOD_SHFS)
$(IPKG_BUILD) $(IDIR_KMOD_SHFS) $(PACKAGE_DIR)