summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package/openswan/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-01 17:30:26 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-01 17:30:26 +0000
commit24dc1f527d33afc44998f5b35a8de368c165f51d (patch)
treea24b15b28fc59486399663b610e84f85d0dd9739 /openwrt/target/linux/package/openswan/Makefile
parent1c7ecc7b70a5848be016ea82df03a176b0a66636 (diff)
fix 2.6 modules pattern using a common LINUX_KMOD_SUFFIX variable,
fix alsa 2.6 build when arch != mipsel git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2311 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package/openswan/Makefile')
-rw-r--r--openwrt/target/linux/package/openswan/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/target/linux/package/openswan/Makefile b/openwrt/target/linux/package/openswan/Makefile
index 0e446902e..3ea5cf7c4 100644
--- a/openwrt/target/linux/package/openswan/Makefile
+++ b/openwrt/target/linux/package/openswan/Makefile
@@ -33,5 +33,5 @@ $(PKG_BUILD_DIR)/.built:
$(IPKG_KMOD_OPENSWAN):
mkdir -p $(IDIR_KMOD_OPENSWAN)/lib/modules/$(LINUX_VERSION)
- cp $(PKG_BUILD_DIR)/modobj/ipsec.*o $(IDIR_KMOD_OPENSWAN)/lib/modules/$(LINUX_VERSION)/
+ cp -fpR $(PKG_BUILD_DIR)/modobj*/ipsec.$(LINUX_KMOD_SUFFIX) $(IDIR_KMOD_OPENSWAN)/lib/modules/$(LINUX_VERSION)/
$(IPKG_BUILD) $(IDIR_KMOD_OPENSWAN) $(PACKAGE_DIR)