summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package/base-files/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-12 06:00:38 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-12 06:00:38 +0000
commitc11b0e50212bdd5a360cae8835ab42cd153a35d6 (patch)
tree59ba95c12665a7ab7ee8c9ff80efc22102da14ca /openwrt/target/linux/package/base-files/Makefile
parent64544ce5225d04bcb62b6a10fe465ce560cb74a5 (diff)
add support for netgear dg834 and the almost identical sphairon jdr454wb: new images, automatic boot loader patcher, updated flash script (dlink.pl renamed to adam2flash.pl) - Thanks to Jonathan McDowell (Noodles)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3221 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package/base-files/Makefile')
-rw-r--r--openwrt/target/linux/package/base-files/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/openwrt/target/linux/package/base-files/Makefile b/openwrt/target/linux/package/base-files/Makefile
index 637904c2e..cf72eabda 100644
--- a/openwrt/target/linux/package/base-files/Makefile
+++ b/openwrt/target/linux/package/base-files/Makefile
@@ -15,8 +15,21 @@ $(PKG_BUILD_DIR)/.prepared:
mkdir -p $(PKG_BUILD_DIR)
touch $@
+ifeq ($(BOARD),ar7)
+$(PKG_BUILD_DIR)/adam2patcher: src/adam2patcher.c
+ $(TARGET_CC) -o $@ $<
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/adam2patcher
+
+$(IDIR_OPENWRT)/sbin/adam2patcher: $(PKG_BUILD_DIR)/adam2patcher
+ mkdir -p $(IDIR_OPENWRT)/sbin
+ $(CP) $(PKG_BUILD_DIR)/adam2patcher $(IDIR_OPENWRT)/sbin
+
+$(IPKG_OPENWRT): $(IDIR_OPENWRT)/sbin/adam2patcher
+endif
+
ifeq ($(BOARD),brcm)
-$(PKG_BUILD_DIR)/jffs2root: jffs2root.c
+$(PKG_BUILD_DIR)/jffs2root: src/jffs2root.c
$(TARGET_CC) -o $@ $<
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/jffs2root