summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 15:36:31 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 15:36:31 +0000
commit4b5c94b6556dbfaa4dd9ff5b31066fa9a4709bd3 (patch)
tree6011fb17694215e612a79229172701debfc81ffd /openwrt/target/linux/package/Makefile
parente12528e55ddb074487a37c757623d2f5e18223f8 (diff)
add board tag to kernel module version and add versioned depend (does not work with current ipkg yet)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1202 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package/Makefile')
-rw-r--r--openwrt/target/linux/package/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index 055bd2ffe..fd66e5a97 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -13,28 +13,27 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
compile: $(patsubst %,%-compile,$(package-y) $(package-m))
install: $(patsubst %,%-install,$(package-y))
-%-prepare:
- $(MAKE) -C $(patsubst %-prepare,%,$@) \
+MAKEOPTS:= BOARD="$(BOARD)" \
TARGET_DIR="$(TARGET_DIR)" \
BUILD_DIR="$(BUILD_DIR)" \
KERNEL_DIR="$(KERNEL_DIR)" \
LINUX_VERSION="$(LINUX_VERSION)" \
+ KERNEL_RELEASE="$(KERNEL_RELEASE)"
+
+
+%-prepare:
+ $(MAKE) -C $(patsubst %-prepare,%,$@) \
+ $(MAKEOPTS) \
prepare
%-compile: %-prepare
$(MAKE) -C $(patsubst %-compile,%,$@) \
- TARGET_DIR="$(TARGET_DIR)" \
- BUILD_DIR="$(BUILD_DIR)" \
- KERNEL_DIR="$(KERNEL_DIR)" \
- LINUX_VERSION="$(LINUX_VERSION)" \
+ $(MAKEOPTS) \
compile
%-install: %-compile
$(MAKE) -C $(patsubst %-install,%,$@) \
- TARGET_DIR="$(TARGET_DIR)" \
- BUILD_DIR="$(BUILD_DIR)" \
- KERNEL_DIR="$(KERNEL_DIR)" \
- LINUX_VERSION="$(LINUX_VERSION)" \
+ $(MAKEOPTS) \
install
%-clean: