summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/linux-2.4
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-29 11:27:13 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-29 11:27:13 +0000
commit062762e5d1f678d368554e092b3c816f26fc8db0 (patch)
tree5d1079cfcd6ba51bd68d8790c4f09dd52cebd605 /openwrt/target/linux/linux-2.4
parentf90ecf844e249a9a2291467db7f027c8f54be536 (diff)
add some options to the lzma kernel compressor for smaller size
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1098 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/linux-2.4')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 9b2f00776..263339f35 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -193,7 +193,7 @@ $(LINUX_KERNEL): $(LINUX_DIR)/$(LINUX_BINLOC)
touch -c $(LINUX_KERNEL)
$(LINUX_IMAGE): $(LINUX_KERNEL)
- cat $^ | $(BUILD_DIR)/lzma/lzma e -si -so -eos > $@ || (rm -f $@ && false)
+ cat $^ | $(BUILD_DIR)/lzma/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
$(LINUX_DIR)/.modules_done: $(LINUX_KERNEL) $(LINUX_IMAGE)
rm -rf $(LINUX_BUILD_DIR)/modules