summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/linux-2.4/Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-02 02:38:07 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-02 02:38:07 +0000
commit3c54c0f6454b062506eb276e77549e6038d5653c (patch)
tree999dc1e011d440751b850e005d92e4050426b486 /openwrt/target/linux/linux-2.4/Makefile
parent9ce5c96cee4ea404749d2b79b949dec988dcc68f (diff)
software watchdog as kernel modul, pf ring as kernel module. saves some bytes in the default images, ideas from 22c3 talking with nbd and sven-ola
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2801 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/linux-2.4/Makefile')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 8cdee42a9..405d1b3ff 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -102,6 +102,10 @@ $(eval $(call KMOD_template,TUN,tun,\
$(MODULES_DIR)/kernel/drivers/net/tun.o \
,CONFIG_TUN,,20,tun))
+$(eval $(call KMOD_template,RING,ring,\
+ $(MODULES_DIR)/kernel/net/ring/ring.o \
+,CONFIG_RING,,20,ring))
+
# Filtering / Firewalling
@@ -361,6 +365,10 @@ $(eval $(call KMOD_template,BLUETOOTH,bluetooth,\
$(MODULES_DIR)/kernel/drivers/bluetooth/*.o \
,CONFIG_BLUEZ))
+$(eval $(call KMOD_template,SOFTDOG,softdog,\
+ $(MODULES_DIR)/kernel/drivers/char/softdog.o \
+,CONFIG_SOFT_WATCHDOG,,95,softdog))
+
$(TARGETS): $(PACKAGE_DIR)