summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-09 16:03:36 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-09 16:03:36 +0000
commitb9efbcf7dd49e086ce43823f8ef522883508eddd (patch)
treecd3926aa82c6d2372aa79180b9a3c22e72c971f6 /openwrt/target/linux/image
parent9040df7d588f52c73bb8be4c0341ba506607fae9 (diff)
add updates for atheros SOC support from Mike A., thx
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2866 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/squashfs.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
index 63eba445a..450718153 100644
--- a/openwrt/target/linux/image/squashfs.mk
+++ b/openwrt/target/linux/image/squashfs.mk
@@ -1,3 +1,10 @@
+ifeq ($(BR2_LINUX_2_4_AR531X),)
+ endian := be
+else
+ endian := le
+endif
+
+
squashfs-prepare:
$(MAKE) -C squashfs prepare $(MAKE_TRACE)
@@ -10,7 +17,7 @@ squashfs-clean:
$(KDIR)/root.squashfs: install-prepare
@mkdir -p $(KDIR)/root/jffs
- $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le $(MAKE_TRACE)
+ $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -$(endian) $(MAKE_TRACE)
ifeq ($(IB),)
squashfs-install: compile-targets $(BOARD)-compile