summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-05 09:58:23 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-05 09:58:23 +0000
commitb788a8d82423625a39deaf21d523b7c1b7743a5e (patch)
tree93b744bdd0af359aca13389c442e5d6993d369a9 /openwrt/target/linux/image
parent3ff4d0bc54268e27995ac9b2360911b09aa91283 (diff)
More au1000 fixes.
Clean up patch Add mount_root specific (different partition naming) Add an init script to kernel command line to set up OpenWrt at boot time git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3730 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/au1000/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/openwrt/target/linux/image/au1000/Makefile b/openwrt/target/linux/image/au1000/Makefile
index 414873189..c7158ca76 100644
--- a/openwrt/target/linux/image/au1000/Makefile
+++ b/openwrt/target/linux/image/au1000/Makefile
@@ -1,8 +1,8 @@
include $(TOPDIR)/rules.mk
LOADADDR = 0x8108c8f4 # RAM start + 16M
-KERNEL_ENTRY = 0x80100000
-RAMSIZE = 0x04000000 # 1MB
+KERNEL_ENTRY = 0x80100000 # Default kernel entry in arch/mips/Makefile
+RAMSIZE = 0x04000000 # 64MB
LOADER_MAKEOPTS= \
KDIR=$(KDIR) \
@@ -28,9 +28,6 @@ $(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
install: $(KDIR)/vmlinux.lzma
endif
-ifeq ($(KERNEL),2.6)
-FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
-
ifeq ($(FS),jffs2-8MB)
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS)
@@ -58,9 +55,6 @@ $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS)
endif
-install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin
-endif
-
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/zImage.flash
$(CP) $^ $@
@@ -78,5 +72,5 @@ install-ib:
mkdir -p $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)
$(CP) $(KDIR)/loader.elf $(IB_DIR)/build_$(ARCH)/
$(CP) $(KDIR)/vmlinux.lzma $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/
- $(TARGET_CROSS)objcopy -O srec $(KDIR)/loader.elf $(KDIR)/loader.srec
+ $(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma 0xbe000000 $(KDIR)/loader.elf $(KDIR)/loader.srec
grep -v S0 $(KDIR)/loader.srec > $(KDIR)/kernel.srec