summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/image/squashfs/patches/100-lzma.patch
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 21:18:26 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 21:18:26 +0000
commita80d25042b8914774c614f8b2ff26e02bcbe0461 (patch)
tree8813ca5ad209754da7f4b71014c7a131ee200196 /openwrt/target/linux/image/squashfs/patches/100-lzma.patch
parent4fba88b87b0e46c76bdc0757e60010affa09f9d0 (diff)
cleanup in target/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1205 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image/squashfs/patches/100-lzma.patch')
-rw-r--r--openwrt/target/linux/image/squashfs/patches/100-lzma.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/squashfs/patches/100-lzma.patch b/openwrt/target/linux/image/squashfs/patches/100-lzma.patch
new file mode 100644
index 000000000..324f8d822
--- /dev/null
+++ b/openwrt/target/linux/image/squashfs/patches/100-lzma.patch
@@ -0,0 +1,22 @@
+--- squashfs2.0/squashfs-tools/Makefile 2004-04-30 19:29:35.000000000 +0400
++++ squashfs-tools/Makefile 2005-01-20 14:57:53.423668596 +0300
+@@ -1,12 +1,18 @@
+ INCLUDEDIR = .
++#LZMAPATH = ../lzma/SRC/7zip/Compress/LZMA_Lib
+
+ CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -O2
+
+ mksquashfs: mksquashfs.o read_fs.o sort.o
+ $(CC) mksquashfs.o read_fs.o sort.o -lz -o $@
+
++mksquashfs-lzma: mksquashfs.o read_fs.o sort.o
++ $(CXX) mksquashfs.o read_fs.o sort.o -L$(LZMAPATH) -llzma -o $@
++
+ mksquashfs.o: mksquashfs.c mksquashfs.h
+
+ read_fs.o: read_fs.c read_fs.h
+
+ sort.o: sort.c
++
++clean:
++ rm -f *.o mksquashfs mksquashfs-lzma