summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/image/squashfs.mk
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 21:18:26 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 21:18:26 +0000
commita80d25042b8914774c614f8b2ff26e02bcbe0461 (patch)
tree8813ca5ad209754da7f4b71014c7a131ee200196 /openwrt/target/linux/image/squashfs.mk
parent4fba88b87b0e46c76bdc0757e60010affa09f9d0 (diff)
cleanup in target/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1205 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image/squashfs.mk')
-rw-r--r--openwrt/target/linux/image/squashfs.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
new file mode 100644
index 000000000..e9a95de56
--- /dev/null
+++ b/openwrt/target/linux/image/squashfs.mk
@@ -0,0 +1,19 @@
+squashfs-prepare:
+ $(MAKE) -C squashfs prepare
+
+squashfs-compile:
+ $(MAKE) -C squashfs compile
+
+squashfs-clean:
+ $(MAKE) -C squashfs clean
+ rm -f $(KDIR)/root.squashfs
+
+$(KDIR)/root.squashfs:
+ @mkdir -p $(KDIR)/root/jffs
+ $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -noappend -root-owned -le
+
+prepare: squashfs-prepare
+compile: squashfs-compile
+install: $(KDIR)/root.squashfs
+ $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
+