summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/image/squashfs.mk
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-14 15:00:56 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-14 15:00:56 +0000
commit8d627f3fc5b90bd3b2349888ec5eefbf3778da41 (patch)
tree6ae7a3842861995a7840e238ffcb58595335f99d /openwrt/target/linux/image/squashfs.mk
parent596ed99c0735a0e91147c3193e88005e46a5bcec (diff)
add new image builder
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1661 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image/squashfs.mk')
-rw-r--r--openwrt/target/linux/image/squashfs.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
index 70a85b99e..42ff77db6 100644
--- a/openwrt/target/linux/image/squashfs.mk
+++ b/openwrt/target/linux/image/squashfs.mk
@@ -14,7 +14,13 @@ $(KDIR)/root.squashfs:
squashfs-install: $(KDIR)/root.squashfs
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
+
+squashfs-install-ib:
+ mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
+ cp $(STAGING_DIR)/bin/mksquashfs-lzma $(IB_DIR)/staging_dir_$(ARCH)/bin
prepare: squashfs-prepare
compile: squashfs-compile
install: squashfs-install
+install-ib: squashfs-install-ib
+clean: squashfs-clean