summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/image/brcm/Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-16 10:12:08 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-16 10:12:08 +0000
commit7ed21d9e57c09f0280889df3924d7c685f515033 (patch)
tree396d907b2130e0287299b9718662df91dd62fe1a /openwrt/target/linux/image/brcm/Makefile
parentb5b8ef08bdbb93686c6feaf76e5ebc8b9f688208 (diff)
use aligned trx for 128kb flash size for netgear, reported by Kaloz
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1931 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image/brcm/Makefile')
-rw-r--r--openwrt/target/linux/image/brcm/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index abba13101..23072bde9 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -30,12 +30,14 @@ $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
ifeq ($(KERNEL),2.6)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
+ifneq ($(FS),jffs2-4MB)
$(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
dd if=$(BUILD_DIR)/loader.elf of=$@ bs=131072 conv=sync
cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx >> $@
install: $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin
endif
+endif
ifeq ($(KERNEL),2.4)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))