summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/image/ar7
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-17 19:47:34 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-17 19:47:34 +0000
commit9e6bdaf5cc3d95140a9f4a94639941c46571dcf9 (patch)
tree5bfc92b8640aea580f4a6dab11a59e84fbe34687 /openwrt/target/linux/image/ar7
parentd8ea33abeb85ecd0c30900248ff90315b53ee14d (diff)
fix ar7 compile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1691 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image/ar7')
-rw-r--r--openwrt/target/linux/image/ar7/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/target/linux/image/ar7/Makefile b/openwrt/target/linux/image/ar7/Makefile
index 8a369edb6..c6a9045b4 100644
--- a/openwrt/target/linux/image/ar7/Makefile
+++ b/openwrt/target/linux/image/ar7/Makefile
@@ -38,7 +38,7 @@ $(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
ifeq ($(IB),)
-$(KDIR)/vmlinux.bin: $(KDIR)/vmlinux.lzma
+$(KDIR)/vmlinux.bin: $(KDIR)/vmlinux.lzma compile
$(TARGET_CROSS)ld -T $(PKG_BUILD_DIR)/zimage.script -r -b binary $< -o $(KDIR)/zimage.o
$(TARGET_CROSS)ld -static -G 0 --defsym kernel_entry=$(KERNEL_ENTRY) -T $(PKG_BUILD_DIR)/ld.script \
$(PKG_BUILD_DIR)/loader.o \
@@ -48,7 +48,7 @@ $(KDIR)/vmlinux.bin: $(KDIR)/vmlinux.lzma
$(TARGET_CROSS)objcopy -O srec $(KDIR)/loader $(KDIR)/ram_zimage.sre
$(STAGING_DIR)/bin/srec2bin $(KDIR)/ram_zimage.sre $@
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-kernel.bin: $(KDIR)/vmlinux.bin
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-kernel.bin: $(KDIR)/vmlinux.bin
endif
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-kernel.bin: