summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/generic-2.6
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-19 09:52:54 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-19 09:52:54 +0000
commit98b32a264e1468e10a818c07844f65e73ed2eb7f (patch)
tree001a29de338c9e0a355686d6be19cf8967b378c8 /openwrt/target/linux/generic-2.6
parente67c058e0dcffc71c8c46ca9f80f7c46d873ae26 (diff)
Add kmod-ipip, closes #539
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3799 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/generic-2.6')
-rw-r--r--openwrt/target/linux/generic-2.6/modules.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/openwrt/target/linux/generic-2.6/modules.mk b/openwrt/target/linux/generic-2.6/modules.mk
index e29360e4d..8157a4c9a 100644
--- a/openwrt/target/linux/generic-2.6/modules.mk
+++ b/openwrt/target/linux/generic-2.6/modules.mk
@@ -18,6 +18,10 @@ $(eval $(call KMOD_template,IMQ,imq,\
$(MODULES_DIR)/kernel/drivers/net/imq.ko \
))
+$(eval $(call KMOD_template,IPIP,ipip,\
+ $(MODULES_DIR)/kernel/net/ipv4/ipip.o \
+,CONFIG_NET_IPIP,,60,ipip))
+
$(eval $(call KMOD_template,IPV6,ipv6,\
$(MODULES_DIR)/kernel/net/ipv6/ipv6.ko \
,CONFIG_IPV6,,20,ipv6))