summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/au1000-2.6
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-02 10:28:13 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-02 10:28:13 +0000
commit857c3cb625f8bfd497f72eeeec2b57358c63d819 (patch)
tree28a5994e63226baea8df5d305cddfb737f42aead /openwrt/target/linux/au1000-2.6
parent05a7af765110f12ca3d35cfb87951c092f9ab8c8 (diff)
Add mips kernel entry patch
Fix image creation git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3723 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/au1000-2.6')
-rw-r--r--openwrt/target/linux/au1000-2.6/Makefile6
-rw-r--r--openwrt/target/linux/au1000-2.6/patches/009-boot.patch15
2 files changed, 18 insertions, 3 deletions
diff --git a/openwrt/target/linux/au1000-2.6/Makefile b/openwrt/target/linux/au1000-2.6/Makefile
index 35ab1034c..4b596f603 100644
--- a/openwrt/target/linux/au1000-2.6/Makefile
+++ b/openwrt/target/linux/au1000-2.6/Makefile
@@ -17,10 +17,10 @@ $(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
@$(CP) config $(LINUX_DIR)/.config
touch $@
-$(LINUX_BUILD_DIR)/zImage: $(LINUX_DIR)/vmlinux
+$(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec
$(MAKE) -C $(LINUX_DIR) V=1 CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) zImage.flash $(MAKE_TRACE)
- $(CP) $(LINUX_DIR)/vmlinux $@
- echo "toto"
+ $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
+ $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
touch $@
compile: $(LINUX_DIR)/vmlinux
diff --git a/openwrt/target/linux/au1000-2.6/patches/009-boot.patch b/openwrt/target/linux/au1000-2.6/patches/009-boot.patch
new file mode 100644
index 000000000..611c70d46
--- /dev/null
+++ b/openwrt/target/linux/au1000-2.6/patches/009-boot.patch
@@ -0,0 +1,15 @@
+diff -Nur linux-cvs/arch/mips/kernel/head.S linux-aruba/arch/mips/kernel/head.S
+--- linux-cvs/arch/mips/kernel/head.S 2004-12-23 00:21:39.000000000 -0800
++++ linux-aruba/arch/mips/kernel/head.S 2005-10-20 09:16:08.000000000 -0700
+@@ -122,6 +122,10 @@
+ #endif
+ .endm
+
++
++ j kernel_entry
++ nop
++
+ /*
+ * Reserved space for exception handlers.
+ * Necessary for machines which link their kernels at KSEG0.
+