summaryrefslogtreecommitdiffstats
path: root/openwrt/target/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
commit725611a466f2edf12f809d22339b22223af4afe7 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/target/Makefile
parentf4dd5a6d7c4ebea48cd6292744cb9def6037de80 (diff)
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@4944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/Makefile')
-rw-r--r--openwrt/target/Makefile41
1 files changed, 0 insertions, 41 deletions
diff --git a/openwrt/target/Makefile b/openwrt/target/Makefile
deleted file mode 100644
index 24c34036d..000000000
--- a/openwrt/target/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-all: install
-
-$(BIN_DIR):
- mkdir -p $(BIN_DIR)
-
-linux-compile: utils-install lzma-install
-linux-install: $(BIN_DIR)
-
-prepare: linux-prepare
-compile: linux-compile
-install: image_clean linux-install
-clean: linux-clean utils-clean lzma-clean image_clean
-
-image_clean:
- rm -f $(BIN_DIR)/openwrt-*
-
-linux/package/%:
- $(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
-
-%-clean:
- @$(TRACE) target/$(patsubst %-clean,%,$@)-clean
- $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-prepare:
- @$(TRACE) target/$(patsubst %-prepare,%,$@)-prepare
- $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-%-compile: %-prepare
- @$(TRACE) target/$(patsubst %-compile,%,$@)-compile
- $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-rebuild:
- @$(TRACE) target/$(patsubst %-rebuild,%,$@)-rebuild
- $(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
-%-install: %-compile
- @$(TRACE) target/$(patsubst %-install,%,$@)-install
- $(MAKE) -C $(patsubst %-install,%,$@) install
-linux-imagebuilder:
- @$(TRACE) target/linux/imagebuilder
- $(MAKE) -C linux imagebuilder
-
-