summaryrefslogtreecommitdiffstats
path: root/openwrt/package
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-12 20:18:17 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-12 20:18:17 +0000
commitfca38b636876e39e44c885b65011fd924971fbbf (patch)
treea2358f37b7fb42d1928c575f71cb6c134160f1f2 /openwrt/package
parenta006abd332ddd398c7ce2968e85c064b3472291e (diff)
add --without-x to dsniff compile and add mostlyclean target
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1222 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/dsniff/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/openwrt/package/dsniff/Makefile b/openwrt/package/dsniff/Makefile
index 6d6b6064b..3355eb88d 100644
--- a/openwrt/package/dsniff/Makefile
+++ b/openwrt/package/dsniff/Makefile
@@ -43,6 +43,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
--sbindir=/usr/sbin \
--sysconfdir=/etc \
--without-db \
+ --without-x \
--with-gdbm="$(STAGING_DIR)/usr" \
--with-libnids="$(STAGING_DIR)/usr" \
--with-libpcap="$(STAGING_DIR)/usr" \
@@ -69,3 +70,7 @@ $(IPKG_DSNIFF):
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/* $(IDIR_DSNIFF)/usr/lib
$(RSTRIP) $(IDIR_DSNIFF)
$(IPKG_BUILD) $(IDIR_DSNIFF) $(PACKAGE_DIR)
+
+mostlyclean:
+ make -C $(PKG_BUILD_DIR) clean
+ rm $(PKG_BUILD_DIR)/.built