summaryrefslogtreecommitdiffstats
path: root/openwrt/package
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-30 20:50:17 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-30 20:50:17 +0000
commitf1dd90e4423f026617ba65f062f48cbd2d5fc778 (patch)
treea0ca5e951452fdf74edf95f8b61f00b705c3a46f /openwrt/package
parent5f26a699ff8b694d72c86a4d141270e4d682d105 (diff)
make the openwrt package dir install the shared includes into the staging dir
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1117 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/openwrt/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/openwrt/Makefile b/openwrt/package/openwrt/Makefile
index 850c8729a..71edbee3a 100644
--- a/openwrt/package/openwrt/Makefile
+++ b/openwrt/package/openwrt/Makefile
@@ -67,6 +67,8 @@ $(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
source: $(DL_DIR)/$(LINKSYS_WLCONF_TGZ)
prepare: $(LINKSYS_WLCONF_DIR)/.unpacked
compile: prepare libnvram-compile libshared-compile $(PKG_IPK) $(PKG_WLCOMPAT)
+ mkdir -p $(STAGING_DIR)/usr/include
+ cp -a ./include/* $(STAGING_DIR)/usr/include/
install: libnvram-install libshared-install \
$(TARGET_DIR)/usr/sbin/wlconf \
$(IPKG_STATE_DIR)/info/$(PKG_NAME).list \