summaryrefslogtreecommitdiffstats
path: root/openwrt/package
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-04 00:13:34 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-04 00:13:34 +0000
commit8f989705ca859f8dc00aa0d689373c32b38d00ca (patch)
tree543acd1c3285a8be6bd33bf3dac34c4033295f95 /openwrt/package
parent06768f3ee0842f5e076c55777ba85e593b14e632 (diff)
revert my changes. didn't work
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1842 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/mtd/Makefile6
-rw-r--r--openwrt/package/mtd/mtd.c4
2 files changed, 1 insertions, 9 deletions
diff --git a/openwrt/package/mtd/Makefile b/openwrt/package/mtd/Makefile
index b2090a6e4..bfbb301e4 100644
--- a/openwrt/package/mtd/Makefile
+++ b/openwrt/package/mtd/Makefile
@@ -7,10 +7,6 @@ PKG_RELEASE := 1
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-ifeq ($(LINUX_VERSION),2.4.30)
-VER=-DLINUX_24
-endif
-
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
@@ -20,7 +16,7 @@ $(PKG_BUILD_DIR)/.prepared:
touch $@
$(PKG_BUILD_DIR)/.built:
- $(TARGET_CC) -I$(LINUX_DIR)/include $(VER) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
+ $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
touch $@
$(IPKG_MTD):
diff --git a/openwrt/package/mtd/mtd.c b/openwrt/package/mtd/mtd.c
index e55986494..69ef06496 100644
--- a/openwrt/package/mtd/mtd.c
+++ b/openwrt/package/mtd/mtd.c
@@ -40,11 +40,7 @@
#include <sys/reboot.h>
#include <string.h>
-#ifdef LINUX_24
#include <linux/mtd/mtd.h>
-#else
-#include <mtd/mtd-user.h>
-#endif
#define TRX_MAGIC 0x30524448 /* "HDR0" */
#define BUFSIZE (10 * 1024)