summaryrefslogtreecommitdiffstats
path: root/openwrt/package
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-04 13:14:29 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-04 13:14:29 +0000
commit217848b1144fca3f4f16812622b517211f0f8a84 (patch)
tree78622815e415ecbe61b820e255decc86e11d40e0 /openwrt/package
parentdb06c4502d91c4d31e89159b77de17615930c867 (diff)
fix include path for glib in nocatsplash
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@555 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/nocatsplash/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/openwrt/package/nocatsplash/Makefile b/openwrt/package/nocatsplash/Makefile
index d5d6b3653..af79e6736 100644
--- a/openwrt/package/nocatsplash/Makefile
+++ b/openwrt/package/nocatsplash/Makefile
@@ -44,10 +44,13 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
);
touch $(PKG_BUILD_DIR)/.configured
+GLIB_CFLAGS :=-I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include
+
$(PKG_BUILD_DIR)/src/splashd: $(PKG_BUILD_DIR)/.configured
$(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC) \
- GLIB_CFLAGS="-I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include" \
+ GLIB_CFLAGS="$(GLIB_CFLAGS)" \
+ AM_CFLAGS="$(TARGET_CFLAGS) $(GLIB_CFLAGS)" \
GLIB_LIBS="-L$(STAGING_DIR)/usr/lib -lglib" \
LIBS="-L$(STAGING_DIR)/usr/lib -lglib"