summaryrefslogtreecommitdiffstats
path: root/openwrt/package
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-06-09 02:05:53 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-06-09 02:05:53 +0000
commit10544fc5942c488f759ae0756ef80b5909711000 (patch)
treeaa238f1c7218309c08955739f9d8ccc76275853f /openwrt/package
parentdd614a2e3813fdefb313bae17b1b022dc165a0c2 (diff)
install missing ebtables files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3923 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/ebtables/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/package/ebtables/Makefile b/openwrt/package/ebtables/Makefile
index 952ac29dd..dae932ea8 100644
--- a/openwrt/package/ebtables/Makefile
+++ b/openwrt/package/ebtables/Makefile
@@ -29,7 +29,13 @@ $(PKG_BUILD_DIR)/.built:
$(IPKG_EBTABLES):
install -d -m0755 $(IDIR_EBTABLES)/etc
install -m0644 $(PKG_BUILD_DIR)/ethertypes $(IDIR_EBTABLES)/etc/
+ install -d -m0755 $(IDIR_EBTABLES)/usr/lib
+ install -m0755 $(PKG_BUILD_DIR)/lib*.so $(IDIR_EBTABLES)/usr/lib/
+ install -d -m0755 $(IDIR_EBTABLES)/usr/lib/ebtables
+ install -m0755 $(PKG_BUILD_DIR)/extensions/*.so $(IDIR_EBTABLES)/usr/lib/ebtables/
install -d -m0755 $(IDIR_EBTABLES)/usr/sbin
install -m0755 $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/
+ install -m0755 $(PKG_BUILD_DIR)/ebtables-save $(IDIR_EBTABLES)/usr/sbin/
+ install -m0755 $(PKG_BUILD_DIR)/ebtables-restore $(IDIR_EBTABLES)/usr/sbin/
$(RSTRIP) $(IDIR_EBTABLES)
$(IPKG_BUILD) $(IDIR_EBTABLES) $(PACKAGE_DIR)