summaryrefslogtreecommitdiffstats
path: root/openwrt/package/wireless-tools/Makefile
diff options
context:
space:
mode:
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-27 10:01:46 +0000
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-27 10:01:46 +0000
commita121d3e51895c4de04a5b9d8c4a78e0627e33daf (patch)
tree02c7f6b4b25254c475d84ebdf257e3f7cd07bc08 /openwrt/package/wireless-tools/Makefile
parentc87ee2f69072af6a0ab2607afedbbc4d6edb98b8 (diff)
do not compile a normal version of wireless-tools just for the shared library
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3054 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/wireless-tools/Makefile')
-rw-r--r--openwrt/package/wireless-tools/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/package/wireless-tools/Makefile b/openwrt/package/wireless-tools/Makefile
index 3f267e37f..71f0a2f21 100644
--- a/openwrt/package/wireless-tools/Makefile
+++ b/openwrt/package/wireless-tools/Makefile
@@ -24,18 +24,18 @@ $(PKG_BUILD_DIR)/.configured:
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -I." \
- all iwmulticall
+ libiw.so.28 iwmulticall
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
PREFIX="$(PKG_INSTALL_DIR)" \
INSTALL_DIR="$(PKG_INSTALL_DIR)/usr/sbin" \
INSTALL_LIB="$(PKG_INSTALL_DIR)/usr/lib" \
- install install-iwmulticall
+ install-iwmulticall
touch $@
$(IPKG_WIRELESS_TOOLS):
mkdir -p $(IDIR_WIRELESS_TOOLS)/usr/lib
- cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libiw.so.28 $(IDIR_WIRELESS_TOOLS)/usr/lib/
+ cp -fpR $(PKG_BUILD_DIR)/libiw.so.28 $(IDIR_WIRELESS_TOOLS)/usr/lib/
mkdir -p $(IDIR_WIRELESS_TOOLS)/usr/sbin
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/iw{config,getid,list,priv,spy} $(IDIR_WIRELESS_TOOLS)/usr/sbin/
$(RSTRIP) $(IDIR_WIRELESS_TOOLS)