summaryrefslogtreecommitdiffstats
path: root/openwrt/package/wificonf
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-02 16:47:17 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-02 16:47:17 +0000
commitcc4e5a8091c2c545d7da199875596c17ed145807 (patch)
treee23ca7c700730086815cff884d8e0fb44943f26b /openwrt/package/wificonf
parent7a69f85e0f5340a3f6f25f5c9706429c9bf6dff0 (diff)
bump wificonf version number, remove wl0_wet variable support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2023 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/wificonf')
-rw-r--r--openwrt/package/wificonf/Makefile2
-rw-r--r--openwrt/package/wificonf/wificonf.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/wificonf/Makefile b/openwrt/package/wificonf/Makefile
index 4dd452955..f6608331b 100644
--- a/openwrt/package/wificonf/Makefile
+++ b/openwrt/package/wificonf/Makefile
@@ -3,7 +3,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=wificonf
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_BUILD_DIR:=$(BUILD_DIR)/wificonf
diff --git a/openwrt/package/wificonf/wificonf.c b/openwrt/package/wificonf/wificonf.c
index 0d652ee15..6bb26b134 100644
--- a/openwrt/package/wificonf/wificonf.c
+++ b/openwrt/package/wificonf/wificonf.c
@@ -430,7 +430,7 @@ void set_wext_mode(skfd, ifname)
/* Set operation mode */
ap = !nvram_match(wl_var("mode"), "sta") && !nvram_match(wl_var("mode"), "wet");
infra = !nvram_disabled(wl_var("infra"));
- wet = nvram_enabled(wl_var("wet")) || !nvram_match(wl_var("mode"), "wet");
+ wet = nvram_match(wl_var("mode"), "wet");
wrq.u.mode = (!infra ? IW_MODE_ADHOC : (ap ? IW_MODE_MASTER : (wet ? IW_MODE_REPEAT : IW_MODE_INFRA)));
IW_SET_EXT_ERR(skfd, ifname, SIOCSIWMODE, &wrq, "Set Mode");