summaryrefslogtreecommitdiffstats
path: root/openwrt/package/vpnc/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-12-14 00:16:01 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-12-14 00:16:01 +0000
commitb4be80dea75f12a0385c3abcb6d1223dde792419 (patch)
treebc070a9c25a401adec9893431f96c2a20691ba9b /openwrt/package/vpnc/Makefile
parent1e93e9797b49ed552338ed23d04dde0ddf00adf5 (diff)
install in /usr instead of /usr/local/,
add an ipkg/conffiles, add an Id tag to the Makefile git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2666 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/vpnc/Makefile')
-rw-r--r--[-rwxr-xr-x]openwrt/package/vpnc/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/openwrt/package/vpnc/Makefile b/openwrt/package/vpnc/Makefile
index 6aec933e7..7513290eb 100755..100644
--- a/openwrt/package/vpnc/Makefile
+++ b/openwrt/package/vpnc/Makefile
@@ -1,3 +1,5 @@
+# $Id$
+
include $(TOPDIR)/rules.mk
PKG_NAME:=vpnc
@@ -21,11 +23,16 @@ $(PKG_BUILD_DIR)/.configured:
touch $@
$(PKG_BUILD_DIR)/.built:
- $(MAKE) STAGING_DIR=$(STAGING_DIR) CC=$(TARGET_CC) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) all install
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC) \
+ STAGING_DIR=$(STAGING_DIR) \
+ DESTDIR=$(PKG_INSTALL_DIR) \
+ PREFIX=/usr \
+ all install
touch $@
$(IPKG_VPNC):
- mkdir -p $(IDIR_VPNC)
+ install -d -m0755 $(IDIR_VPNC)
cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VPNC)/
$(RSTRIP) $(IDIR_VPNC)
$(IPKG_BUILD) $(IDIR_VPNC) $(PACKAGE_DIR)