summaryrefslogtreecommitdiffstats
path: root/openwrt/package/vnc-reflector
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
commit725611a466f2edf12f809d22339b22223af4afe7 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/package/vnc-reflector
parentf4dd5a6d7c4ebea48cd6292744cb9def6037de80 (diff)
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@4944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/vnc-reflector')
-rwxr-xr-xopenwrt/package/vnc-reflector/Config.in14
-rw-r--r--openwrt/package/vnc-reflector/Makefile35
-rwxr-xr-xopenwrt/package/vnc-reflector/ipkg/vnc-reflector.control6
-rw-r--r--openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch25
4 files changed, 0 insertions, 80 deletions
diff --git a/openwrt/package/vnc-reflector/Config.in b/openwrt/package/vnc-reflector/Config.in
deleted file mode 100755
index 22679fced..000000000
--- a/openwrt/package/vnc-reflector/Config.in
+++ /dev/null
@@ -1,14 +0,0 @@
-config BR2_PACKAGE_VNC_REFLECTOR
- prompt "vnc-reflector..................... VNC proxy for multiple clients"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBJPEG
- select BR2_PACKAGE_ZLIB
- help
- VNC Reflector is a specialized VNC server which acts as
- a proxy sitting between real VNC server (a host) and a
- number of VNC clients. It was designed to work efficiently
- with large number of clients.
-
- http://sourceforge.net/projects/vnc-reflector
-
diff --git a/openwrt/package/vnc-reflector/Makefile b/openwrt/package/vnc-reflector/Makefile
deleted file mode 100644
index 00d1cbad0..000000000
--- a/openwrt/package/vnc-reflector/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=vnc-reflector
-PKG_VERSION:=1.2.4
-PKG_RELEASE:=1
-PKG_MD5SUM:=c3f88bc62f228b335c25c07f9744ab0c
-
-PKG_SOURCE_URL:=@SF/vnc-reflector
-PKG_SOURCE:=vnc_reflector-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/vnc_reflector
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,VNC_REFLECTOR,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) \
- OFLAGS="$(TARGET_CFLAGS)" \
- STAGING_DIR=$(STAGING_DIR) \
- default
- touch $@
-
-$(IPKG_VNC_REFLECTOR):
- install -d -m0755 $(IDIR_VNC_REFLECTOR)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/vncreflector $(IDIR_VNC_REFLECTOR)/usr/sbin/
- $(RSTRIP) $(IDIR_VNC_REFLECTOR)
- $(IPKG_BUILD) $(IDIR_VNC_REFLECTOR) $(PACKAGE_DIR)
diff --git a/openwrt/package/vnc-reflector/ipkg/vnc-reflector.control b/openwrt/package/vnc-reflector/ipkg/vnc-reflector.control
deleted file mode 100755
index 293a0a070..000000000
--- a/openwrt/package/vnc-reflector/ipkg/vnc-reflector.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: vnc-reflector
-Depends: jpeg, zlib
-Section: net
-Architecture: mipsel
-Priority: optional
-Description: VNC Reflector is a specialized VNC server which acts as a proxy sitting between real VNC server (a host) and a number of VNC clients. It was designed to work efficiently with large number of clients.
diff --git a/openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch b/openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch
deleted file mode 100644
index fb409ac43..000000000
--- a/openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- vnc_reflector/Makefile.orig 2005-12-14 01:25:53.000000000 +0100
-+++ vnc_reflector/Makefile 2005-12-14 01:28:05.000000000 +0100
-@@ -14,10 +14,11 @@
- #
- # Variables you might want to edit: CFLAGS, CONFFLAGS
-
--IFLAGS = -I.
-+IFLAGS = -I. -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
-+OFLAGS = -O2
-
- # Production
--CFLAGS = -O2 $(IFLAGS)
-+CFLAGS = $(OFLAGS) $(IFLAGS)
- # Debug (strict)
- #CFLAGS = -g -pedantic -Wall $(IFLAGS)
- # Debug (profiling)
-@@ -29,7 +30,7 @@
- CONFFLAGS = -DUSE_POLL
-
- # Link with zlib and JPEG libraries
--LDFLAGS = -L/usr/local/lib -lz -ljpeg
-+LDFLAGS = -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lz -ljpeg
-
- PROG = vncreflector
-