summaryrefslogtreecommitdiffstats
path: root/openwrt/package/templates.mk
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-09 09:33:23 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-09 09:33:23 +0000
commit083dd6a64edd862625e6d06072874b25a1991971 (patch)
tree78837e83f94a179a38950009e74a4153f06bbb87 /openwrt/package/templates.mk
parentab26d6ba206ec2ab1d889b6df9608d6ce736b892 (diff)
merge nico's package/rules.mk and package/templates.mk into one file, update packages that use this
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@817 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/templates.mk')
-rw-r--r--openwrt/package/templates.mk22
1 files changed, 0 insertions, 22 deletions
diff --git a/openwrt/package/templates.mk b/openwrt/package/templates.mk
deleted file mode 100644
index c60d9ce01..000000000
--- a/openwrt/package/templates.mk
+++ /dev/null
@@ -1,22 +0,0 @@
-# $(call PKG_template,EXAMPLE,example,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-define PKG_template
-
-IPKG_$(1):=$(PACKAGE_DIR)/$(2)_$(3)_$(4).ipk
-IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(2)
-INFO_$(1):=$(IPKG_STATE_DIR)/info/$(2).list
-
-PKG_FILES += $$(IPKG_$(1))
-ifneq ($(BR2_PACKAGE_$(1)),)
-COMPILE_TARGETS += $$(IPKG_$(1))
-endif
-ifeq ($(BR2_PACKAGE_$(1)),y)
-INSTALL_TARGETS += $$(INFO_$(1))
-endif
-
-$$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
- $(SCRIPT_DIR)/make-ipkg-dir.sh $$(IDIR_$(1)) ./ipkg/$(2).control $(3) $(4)
-
-$$(INFO_$(1)): $$(IPKG_$(1))
- $(IPKG) install $$(IPKG_$(1))
-
-endef