summaryrefslogtreecommitdiffstats
path: root/openwrt/package/samba/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-29 07:04:02 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-29 07:04:02 +0000
commitdad4d0ea840f61dc912d1bb1f9118058e2cb6c23 (patch)
tree4bd4f592fe39cc4f8d98c1fd874b5e03e79623a1 /openwrt/package/samba/Makefile
parentb9037feb2e9c8bb23858d7143f355e9564f2c9ac (diff)
add missing codepages, add syslog support and use it by default
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1996 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/samba/Makefile')
-rw-r--r--openwrt/package/samba/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/samba/Makefile b/openwrt/package/samba/Makefile
index 7a083b3a4..566e604a0 100644
--- a/openwrt/package/samba/Makefile
+++ b/openwrt/package/samba/Makefile
@@ -119,6 +119,7 @@ $(PKG_BUILD_DIR)/.built:
$(DISABLE_NLS) \
--with-lockdir=/var/run/samba \
--with-privatedir=/etc/samba \
+ --with-syslog \
);
$(MAKE) -C $(PKG_BUILD_DIR)/source \
$(TARGET_CONFIGURE_OPTS) \
@@ -160,6 +161,7 @@ $(IPKG_SAMBA):
install -m0755 $(PKG_BUILD_DIR)/source/bin/smbd.shared $(IDIR_SAMBA)/usr/sbin/smbd
install -d -m0755 $(IDIR_SAMBA)/usr/share/samba
install -m0644 $(PKG_INSTALL_DIR)/usr/share/samba/codepage.{437,850} $(IDIR_SAMBA)/usr/share/samba/
+ install -m0644 $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{437,850} $(IDIR_SAMBA)/usr/share/samba/
$(RSTRIP) $(IDIR_SAMBA)
$(IPKG_BUILD) $(IDIR_SAMBA) $(PACKAGE_DIR)