summaryrefslogtreecommitdiffstats
path: root/openwrt/package/samba/Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-04 08:37:19 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-04 08:37:19 +0000
commitbd4525f44b73dc92588263f1dd9686731c286213 (patch)
treef381f2461a56d23bcdfe066e594418cae18fa846 /openwrt/package/samba/Makefile
parente758f86a63f8f463b7a4224039ea83a51810b51f (diff)
patch for spec file of gcc 3.4.4, so that libgss library is not
automatically linked into every binary. explicitely link it into needed packages (kismet, nmap, samba) and add dependencies. idea and patch from sven-ola, thx. Saves 16 kb in the default squashfs images. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2817 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/samba/Makefile')
-rw-r--r--openwrt/package/samba/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/package/samba/Makefile b/openwrt/package/samba/Makefile
index 566e604a0..584ed9a04 100644
--- a/openwrt/package/samba/Makefile
+++ b/openwrt/package/samba/Makefile
@@ -58,7 +58,7 @@ $(PKG_BUILD_DIR)/.built:
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -DNDEBUG -DSHMEM_SIZE=524288 -Dfcntl=fcntl64" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+ LDFLAGS="-lgcc_s -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
ac_cv_lib_cups_httpConnect=no \
ac_cv_sizeof_int=4 \
ac_cv_sizeof_long=4 \