summaryrefslogtreecommitdiffstats
path: root/openwrt/package/sablevm
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
commit725611a466f2edf12f809d22339b22223af4afe7 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/package/sablevm
parentf4dd5a6d7c4ebea48cd6292744cb9def6037de80 (diff)
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@4944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/sablevm')
-rw-r--r--openwrt/package/sablevm/Config.in18
-rw-r--r--openwrt/package/sablevm/Makefile68
-rw-r--r--openwrt/package/sablevm/ipkg/sablevm.control5
-rw-r--r--openwrt/package/sablevm/patches/001-heap_size.patch15
4 files changed, 0 insertions, 106 deletions
diff --git a/openwrt/package/sablevm/Config.in b/openwrt/package/sablevm/Config.in
deleted file mode 100644
index 289701822..000000000
--- a/openwrt/package/sablevm/Config.in
+++ /dev/null
@@ -1,18 +0,0 @@
-config BR2_PACKAGE_SABLEVM
- prompt "sablevm........................... A Java Virtual Machine (JVM) implementation"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBFFI_SABLE
- select BR2_PACKAGE_LIBLTDL
- select BR2_PACKAGE_LIBPOPT
- select BR2_PACKAGE_LIBPTHREAD
- select BR2_PACKAGE_ZLIB
- help
- SableVM is a robust, extremely portable, efficient, and specifications-
- -compliant Java virtual machine that aims to be easy to maintain and to
- extend. It features a state-of-the-art and efficient interpreter engine.
- Its source code is very accessible and easy to understand. It also has
- many robustness features that have been the object of careful design.
-
- http://sablevm.org/
-
diff --git a/openwrt/package/sablevm/Makefile b/openwrt/package/sablevm/Makefile
deleted file mode 100644
index d09b11684..000000000
--- a/openwrt/package/sablevm/Makefile
+++ /dev/null
@@ -1,68 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=sablevm
-PKG_VERSION:=1.13
-PKG_RELEASE:=1
-PKG_MD5SUM:=d5828200032bfe921dd43e450931e38c
-
-PKG_SOURCE_URL:=http://sablevm.org/download/release/$(PKG_VERSION)/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-BR2_PACKAGE_SABLEVM=m
-
-$(eval $(call PKG_template,SABLEVM,sablevm,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(strip $(TARGET_CFLAGS))" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -lffi -lltdl -lpopt -lz" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --disable-static \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_SABLEVM):
- install -m0755 -d $(IDIR_SABLEVM)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/{java-,}sablevm $(IDIR_SABLEVM)/usr/bin/
- install -m0755 -d $(IDIR_SABLEVM)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsablevm-*.so $(IDIR_SABLEVM)/usr/lib/
- $(RSTRIP) $(IDIR_SABLEVM)
- $(IPKG_BUILD) $(IDIR_SABLEVM) $(PACKAGE_DIR)
diff --git a/openwrt/package/sablevm/ipkg/sablevm.control b/openwrt/package/sablevm/ipkg/sablevm.control
deleted file mode 100644
index 516fc72b3..000000000
--- a/openwrt/package/sablevm/ipkg/sablevm.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: sablevm
-Priority: optional
-Section: misc
-Description: A Java Virtual Machine (JVM) implementation
-Depends: libffi-sable, libltdl, libpopt, libpthread, zlib
diff --git a/openwrt/package/sablevm/patches/001-heap_size.patch b/openwrt/package/sablevm/patches/001-heap_size.patch
deleted file mode 100644
index d28237296..000000000
--- a/openwrt/package/sablevm/patches/001-heap_size.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -ruN sablevm-1.11.1-orig/src/libsablevm/system.h sablevm-1.11.1-1/src/libsablevm/system.h
---- sablevm-1.11.1-orig/src/libsablevm/system.h 2005-03-18 01:25:09.000000000 +0100
-+++ sablevm-1.11.1-1/src/libsablevm/system.h 2005-03-22 01:05:19.000000000 +0100
-@@ -279,9 +279,9 @@
-
- #elif defined (_SABLEVM_COPY_GC) || (_SABLEVM_GENCOPY_GC)
-
--#define SVM_HEAP_DEFAULT_MIN_SIZE 16777216
-+#define SVM_HEAP_DEFAULT_MIN_SIZE 1048576
- #define SVM_HEAP_DEFAULT_MAX_SIZE 0
--#define SVM_HEAP_DEFAULT_ALLOCATION_INCREMENT 1048576
-+#define SVM_HEAP_DEFAULT_ALLOCATION_INCREMENT 65536
-
- #if defined (_SABLEVM_GENCOPY_GC)
-