summaryrefslogtreecommitdiffstats
path: root/openwrt/package/ppp/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-26 15:52:12 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-26 15:52:12 +0000
commit908bf643e0a9637d3a7b0ba23e673f8b505151f4 (patch)
tree20778c53fcbef2bc8ed5a08e08f4665a35afa81f /openwrt/package/ppp/Makefile
parent28bce5255adbc39008a42bc3bb9801c57642dd8b (diff)
clean up board-dependent files, add pppoatm support, add proper config examples
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1754 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/ppp/Makefile')
-rw-r--r--openwrt/package/ppp/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/openwrt/package/ppp/Makefile b/openwrt/package/ppp/Makefile
index 0fed25c91..1b20c4e7c 100644
--- a/openwrt/package/ppp/Makefile
+++ b/openwrt/package/ppp/Makefile
@@ -28,12 +28,14 @@ $$(IPKG_$(1)):
endef
$(eval $(call PKG_template,PPP,ppp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,PPP_MOD_PPPOA,ppp-mod-pppoa,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,PPP_MOD_PPPOE,ppp-mod-pppoe,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,PPP_MOD_RADIUS,ppp-mod-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,CHAT,chat,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,PPPDUMP,pppdump,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,PPPSTATS,pppstats,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_mod_template,PPP_MOD_PPPOA,pppoatm))
$(eval $(call PKG_mod_template,PPP_MOD_PPPOE,rp-pppoe))
$(eval $(call PKG_mod_template,PPP_MOD_RADIUS,radius))
@@ -88,6 +90,12 @@ $(IPKG_PPP):
$(RSTRIP) $(IDIR_PPP)
$(IPKG_BUILD) $(IDIR_PPP) $(PACKAGE_DIR)
+$(IDIR_PPP_MOD_PPPOA)/sbin/ifup.pppoa:
+ install -d -m0755 $(IDIR_PPP_MOD_PPPOA)/sbin
+ install -m0755 ./files/ifup.pppoa $(IDIR_PPP_MOD_PPPOA)/sbin/
+
+$(IPKG_PPP_MOD_PPPOA): $(IDIR_PPP_MOD_PPPOA)/sbin/ifup.pppoa
+
$(IDIR_PPP_MOD_PPPOE)/sbin/ifup.pppoe:
install -d -m0755 $(IDIR_PPP_MOD_PPPOE)/sbin
install -m0755 ./files/ifup.pppoe $(IDIR_PPP_MOD_PPPOE)/sbin/