summaryrefslogtreecommitdiffstats
path: root/openwrt/package/postgresql/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-20 20:35:04 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-20 20:35:04 +0000
commit9940e88454f754481bb1fced5df097dab527f369 (patch)
tree87cd4158c19ef3496d3594289644f17b3b58d210 /openwrt/package/postgresql/Makefile
parent2c95e0bbc78192bafb0ce5de75f1984f42b544e6 (diff)
build pg_config too and install it to staging_dir
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2202 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/postgresql/Makefile')
-rw-r--r--openwrt/package/postgresql/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/openwrt/package/postgresql/Makefile b/openwrt/package/postgresql/Makefile
index d83f1afb8..12e712f50 100644
--- a/openwrt/package/postgresql/Makefile
+++ b/openwrt/package/postgresql/Makefile
@@ -76,6 +76,11 @@ $(PKG_BUILD_DIR)/.built:
$(MAKE) -C "$(PKG_BUILD_DIR)/src/interfaces/libpq" \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
+ $(MAKE) -C "$(PKG_BUILD_DIR)/src/bin/pg_config" \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ includedir="$(STAGING_DIR)/usr/include" \
+ libdir="$(STAGING_DIR)/usr/lib" \
+ all install
$(MAKE) -C "$(PKG_BUILD_DIR)/src/bin/psql" \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
@@ -94,6 +99,8 @@ $(IPKG_PGSQL_CLI):
$(IPKG_BUILD) $(IDIR_PGSQL_CLI) $(PACKAGE_DIR)
$(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
+ mkdir -p $(STAGING_DIR)/usr/bin
+ cp -fpR $(PKG_INSTALL_DIR)/usr/bin/pg_config $(STAGING_DIR)/usr/bin/
mkdir -p $(STAGING_DIR)/usr/include
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
@@ -108,6 +115,7 @@ install-dev: $(STAGING_DIR)/usr/lib/libpq.so
uninstall-dev:
rm -rf \
+ $(STAGING_DIR)/usr/bin/pg_config \
$(STAGING_DIR)/usr/include/libpq \
$(STAGING_DIR)/usr/include/libpq-fe.h \
$(STAGING_DIR)/usr/include/pg_config.h \