summaryrefslogtreecommitdiffstats
path: root/openwrt/package/popt/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-09 09:33:23 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-09 09:33:23 +0000
commit083dd6a64edd862625e6d06072874b25a1991971 (patch)
tree78837e83f94a179a38950009e74a4153f06bbb87 /openwrt/package/popt/Makefile
parentab26d6ba206ec2ab1d889b6df9608d6ce736b892 (diff)
merge nico's package/rules.mk and package/templates.mk into one file, update packages that use this
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@817 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/popt/Makefile')
-rw-r--r--openwrt/package/popt/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/openwrt/package/popt/Makefile b/openwrt/package/popt/Makefile
index 7297ce7b0..64e2e169b 100644
--- a/openwrt/package/popt/Makefile
+++ b/openwrt/package/popt/Makefile
@@ -16,14 +16,9 @@ PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/package/templates.mk
-
-$(eval $(call PKG_template,LIBPOPT,libpopt,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
include $(TOPDIR)/package/rules.mk
-COMPILE_TARGETS += install-dev
-CLEAN_TARGETS += uninstall-dev
+$(eval $(call PKG_template,LIBPOPT,libpopt,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
@@ -79,3 +74,6 @@ uninstall-dev:
-$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(STAGING_DIR)" \
uninstall
+
+compile: install-dev
+clean: uninstall-dev