summaryrefslogtreecommitdiffstats
path: root/openwrt/package/picocom/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
commit725611a466f2edf12f809d22339b22223af4afe7 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/package/picocom/Makefile
parentf4dd5a6d7c4ebea48cd6292744cb9def6037de80 (diff)
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@4944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/picocom/Makefile')
-rw-r--r--openwrt/package/picocom/Makefile36
1 files changed, 0 insertions, 36 deletions
diff --git a/openwrt/package/picocom/Makefile b/openwrt/package/picocom/Makefile
deleted file mode 100644
index f71665dd6..000000000
--- a/openwrt/package/picocom/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=picocom
-PKG_VERSION:=1.4
-PKG_RELEASE:=1
-PKG_MD5SUM:=08fcc5f6bb9e7676a2569386d5ea9f70
-
-PKG_SOURCE_URL:=http://efault.net/npat/hacks/picocom/dist/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,PICOCOM,picocom,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
- CFLAGS="$(TARGET_CFLAGS) -L$(STAGING_DIR)/usr/lib" \
- picocom
- touch $@
-
-$(IPKG_PICOCOM):
- install -d -m0755 $(IDIR_PICOCOM)/usr/bin
- install -m0755 $(PKG_BUILD_DIR)/picocom $(IDIR_PICOCOM)/usr/bin/
- $(RSTRIP) $(IDIR_PICOCOM)
- $(IPKG_BUILD) $(IDIR_PICOCOM) $(PACKAGE_DIR)