summaryrefslogtreecommitdiffstats
path: root/openwrt/package/openldap
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-10 16:06:24 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-10 16:06:24 +0000
commit14428f9a610d763126cbcf9b841dd2140aa7d8eb (patch)
tree8d5d1cb1834673f54bf26163e53efd692657d167 /openwrt/package/openldap
parent62ad947afed2dc3df42d295eec5c0afb0fbca513 (diff)
Fix building when host and target systems are same arch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1597 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/openldap')
-rw-r--r--openwrt/package/openldap/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/openldap/Makefile b/openwrt/package/openldap/Makefile
index 35a15b37e..20179b271 100644
--- a/openwrt/package/openldap/Makefile
+++ b/openwrt/package/openldap/Makefile
@@ -78,7 +78,7 @@ $(PKG_BUILD_DIR)/.built:
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
ac_cv_func_memcmp_clean="yes" \
./configure \
--target=$(GNU_TARGET_NAME) \
@@ -128,7 +128,7 @@ $(STAGING_DIR)/usr/lib/libldap.so: $(PKG_BUILD_DIR)/.built
cp -fpR $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib/
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(STAGING_DIR)/usr/lib/
- touch $(STAGING_DIR)/usr/lib/libldap.so
+ touch $@
install-dev: $(STAGING_DIR)/usr/lib/libldap.so