summaryrefslogtreecommitdiffstats
path: root/openwrt/package/mtd/Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-14 15:30:53 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-14 15:30:53 +0000
commitc6e1844142debd353a711d6ea0295f0d2c0fe218 (patch)
treebe7307317f63201afe3eb8bccaffea5fa5a3fb35 /openwrt/package/mtd/Makefile
parent04710b869a2ca712da79f533e40d424f68d345d4 (diff)
sync with whiterussian
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1923 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/mtd/Makefile')
-rw-r--r--openwrt/package/mtd/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/openwrt/package/mtd/Makefile b/openwrt/package/mtd/Makefile
index bfbb301e4..18ebc9033 100644
--- a/openwrt/package/mtd/Makefile
+++ b/openwrt/package/mtd/Makefile
@@ -3,13 +3,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME := mtd
-PKG_RELEASE := 1
+PKG_RELEASE := 2
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,MTD_STATIC,mtd-static,$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.prepared:
mkdir -p $@
@@ -17,6 +18,7 @@ $(PKG_BUILD_DIR)/.prepared:
$(PKG_BUILD_DIR)/.built:
$(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
+ $(TARGET_CC) -static $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd-static mtd.c
touch $@
$(IPKG_MTD):
@@ -24,3 +26,9 @@ $(IPKG_MTD):
install -m0755 $(PKG_BUILD_DIR)/mtd $(IDIR_MTD)/sbin
$(RSTRIP) $(IDIR_MTD)/sbin/*
$(IPKG_BUILD) $(IDIR_MTD) $(PACKAGE_DIR)
+
+$(IPKG_MTD_STATIC):
+ install -d -m0755 $(IDIR_MTD_STATIC)/sbin
+ install -m0755 $(PKG_BUILD_DIR)/mtd-static $(IDIR_MTD_STATIC)/sbin
+ $(RSTRIP) $(IDIR_MTD_STATIC)/sbin/*
+ $(IPKG_BUILD) $(IDIR_MTD_STATIC) $(PACKAGE_DIR)